Intermittent Connectivity Issues Due to AWS US-WEST-2 Infrastructure Event

Incident Report for Deepgram

Resolved

This incident has been resolved.
Posted Jul 24, 2026 - 13:22 UTC

Investigating

Between approximately 10:55 and 12:00 UTC on July 24, an upstream infrastructure issue in AWS's US-WEST-2 region caused intermittent connectivity problems that may have affected Deepgram services and customer infrastructure — including elevated errors, connection timeouts, and failures fetching remotely hosted media for some requests.

The underlying cause was an AWS networking issue affecting routing to the US-WEST-2 region. AWS applied mitigations and fully restored connectivity by ~12:00 UTC. We have confirmed recovery and are continuing to monitor.

Details on the underlying AWS event are available on the AWS Health status page: https://health.aws.amazon.com/health/status
Posted Jul 24, 2026 - 13:18 UTC