Increased Latency Over Streaming STT and Voice Agent API

Incident Report for Deepgram

Resolved

This issue has been resolved.
Posted Oct 28, 2025 - 16:20 UTC

Monitoring

The increased latency issue has significantly improved. We will continue to monitor the performance.
Posted Oct 28, 2025 - 16:20 UTC

Update

We identified a potential source of increased latency and are currently monitoring a mitigation step.
Posted Oct 28, 2025 - 16:00 UTC

Investigating

We are currently investigating increased latency over our streaming STT API and Voice Agent API.
Posted Oct 28, 2025 - 14:02 UTC
This incident affected: Deepgram Public API (api.deepgram.com) (Streaming API, Voice Agent API).